Overview
For when Realtime isn't connecting. You will see the error below when you click on Agent Timeline, Group Timeline, or Realtime Stats.
Possible Causes
- Realtime Node Service Installed on Chronicall Server
- Blocked Realtime Port
- Chronicall IP Address (Check the Chronicall IP address on Realtime Node for example in Documentbase)
- Different Subnet (Determine if Chronicall and Realtime Node are on the same or different subnets)
- Unregistered Serial Key
- Datagrid not connecting (3.12 and earlier)
Resolutions
Realtime Node Installed in error on Chronicall Server
Note: If the Realtime Node was installed on the Chronicall Server purposefully for Realtime to function, please ignore this section.
- Open Services Application and look for a service called Chronicall Realtime Node
- If the service is present, stop it
- Uninstall the Chronicall Realtime Node service by following this uninstall guide
Blocked Realtime Port
- Inside Chronicall, select Admin (System) > System Settings
- Select Advanced Settings, then click on the ellipses next to Realtime Nodes in the lower right of this screenshot
- Here you will see what local port Chronicall Realtime is using. If it is set to 9092, try changing it to 10092 here, and then restart the Chronicall service
- If you are on Chronicall 3.9 or earlier, you will also want to verify the IP address on this screen matches that of the Chornicall server. Use the actual IP address and not a localhost address if you have the option here.
- If you are on Chronicall 3.9 or earlier, you will also want to verify the IP address on this screen matches that of the Chornicall server. Use the actual IP address and not a localhost address if you have the option here.
- Log back into Chronicall and select Agent Timeline, Group Timeline, or Realtime Stats to verify it is now working.
Unregistered Serial Key
Please see this article if you have an unregistered serial key. It is possible some hardware changed, another server registered your serial key, or your company has purchased a different serial key to migrate to. You will need to contact our support team per the article linked here if you need your infohash reset, which is usually due to a local hardware change such as a RAM upgrade.
Datagrid Not Connecting, corrupt Node.pid (Chronicall 3.12.6 and earlier)
This is an issue that is no longer present in newer 4.0 builds since we no longer use a datagrid, but may be present on builds 3.12.6 and earlier. Please see this attached article for more information.