Issue Description
There is a known issue that will affect sites using HTTPS and SSL due to their certifications expiring after 90 days.
Cause
The Nginx certifications expire every 3 months and are not renewing automatically
Resolution
There is a temporary stopgap for customers who need to get back up and running as soon as possible, and there is a permanent fix for those able to run an update file after hours.
Stop Gap Steps
- Stop all Chronicall services
- Follow these steps if using Multimedia or Contact Center
- Stop the nginx process
- Windows
- Open Task Manager
- Find the nginx.exe process in the Processes tab
- Right-click the nginx.exe process and select "End Process"
- Linux
- Use the
ps aux | grep nginx
command to find the PID of the nginx process - Use the appropriate
kill
command for your version of Linux to end the process
- Use the
- Windows
- Navigate to the main Chronicall/ACR folder
- E.g.
C:\Program Files\Avaya Call Reporting
C:\Program Files\Chronicall
C:\Program Files (x86)\Chronicall
/var/lib/Avata \Call \Reporting
/var/lib/Chronicall
- E.g.
- Rename the nginx folder so Chronicall/ACR will rebuild it and download a fresh cert on the next service restart
- E.g. change it from
nginx
tonginx.old
- E.g. change it from
- Restart all services
Permanent Fix Steps
- Navigate to the Downloads page for your brand of software
- Chronicall
- Avaya Call Reporting
- Run the update during your company's downtime by following our Updating Chronicall guide
- It is always recommended to run update/upgrades after hours and to perform a database backup beforehand