When attempting to access Chronicall via the Desktop Client, Browserless app or Web Interface, the following error message is shown:
There was an error loading Chronicall Desktop
java.ioFileNotFoundException: http://localhost:9080/desktop
Cause
There are a few common causes of this issue.
Please note that this only applies to older versions. The Tomcat-users file does not exist in 3.10, but there may still be an issue with the web.xml file.
- Chronicall Server Hard Drive is full
- A corrupt or missing tomcat-users.xml or a missing web.xml file
- The custom Java paths have changed
- Settings.xml file is corrupt
Resolution
Check HDD Space
- Log into the Chronicall server.
- Ensure that the Hard Disk Drive Chronicall is installed on is not full.
- If you notice that the hard disk is running out of storage you can delete any old tomcat logs if they are taking up an excessive amount of room.
Tomcat-users.xml Corrupt (Does not exist in Chronicall 3.10 and above)
- Stop all Chronicall services
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Note: This will stop all logging, recording, and call routing. Multimedia customers will lose any calls in queue or calls might get stuck in the queue.
-
- If on Windows Server, look for any rogue Chronicall processes in the Task Manager. If found, End Task.
- Verify the Java path in the chronicallw folder
- You can refer to step 5 and 6 On This Article to verify the Java path is still valid.
- Locate the tomcat-users.xml at the following file path:
- Windows
-
C:\Program Files (x86)\Xima Software\Chronicall\tomcat\conf\tomcat-users.xml
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- Linux
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/var/lib/Xima\ Software/Chronicall\tomcat\conf\tomcat-users.xml
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- Windows
- Open the file, and verify the text is in the same format as shown:
- If not, download the tomcat-users.xml attachment located at the bottom of this article to replace the file.
- Restart all Chronicall Services
Web.xml Corrupt
- Stop all Chronicall/ACR services
-
Note: this will stop all logging, recording, and call routing. Multimedia customers will lose any calls in queue or calls might get stuck in the queue.
-
- If on Windows Server, look for any rogue Chronicall/ACR processes in the Task Manager. If found, End Task.
- Verify the Java Path in the chronicallw folder
- You can refer to step 5 and 6 On This Article to verify the Java path is still valid.
- Locate the web.xml at the following file path and open the file.
- Windows
-
C:\Program Files (x86)\Xima Software\Chronicall\tomcat\webapps\ROOT\WEB-INF
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- Linux
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/var/lib/Xima\ Software/Chronicall\tomcat\webapps\ROOT\WEB-INF
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- Windows
- Open the file, and verify the text is in the same format as shown:
- If the folder is: missing the web.xml file, the file is blank or it doesn't appear as above; download the web.xml attachment located at the bottom of this article to replace the file.
- Restart all Chronicall Services
Settings.xml corrupt
- Navigate to the Chronicall directory (path above) to locate the settings.xml file.
- Stop all Chronicall related services (if you are not a Multimedia site) and move the settings.xml file to the desktop so you have a copy of it in case anything goes wrong.
- Change the settings.bak file name to settings.xml after copying settings.bak to the desktop as well.
- Startup Chronicall services again, and test Chronicall for functionality.
Settings.xml missing or path.txt incorrect (Linux)
- Navigate to the /etc/chronicall directory in Linux
- You should see a settings.xml file in that directory
- If you do not, copy the settings file from the Chronicall/ACR directory and paste it here
- If you do not, copy the settings file from the Chronicall/ACR directory and paste it here
- Open the path.txt file and verify that the path inside is the actual path to Chronicall/ACR
- If it is not, change it to the correct path, then save the file