Overview
The following steps can be used to troubleshoot when an individual agent is not receiving the desired pop-ups or is receiving inconsistent pop-up alerts.
Cause
Potential causes could include:
- The agent is authenticated to the Chronicall Desktop application and not the Agent Dashboard.
- The user does not have the proper Agent Dashboard licenses.
- The Agent Dashboard is not properly configured.
- Pop-ups are not enabled.
- Bad network connection to the Chronicall server.
Resolution
Verify Login Method
Chronicall Desktop functions as a dual launcher. If the agent selects their username and extension (password is their extension) they will be authenticated to the Agent Dashboard. If the agent selects their Chronicall username and password they will be authenticated to the Chronicall Desktop application.
Be sure the user is authenticating to the Agent Dashboard and not Chronicall Desktop. A blue Xima icon will be visible in the bottom right taskbar on the Agent's computer when properly authenticated to the Agent Dashboard application as shown:
Verify Licensing
The Agent Dashboard requires the following Chronicall user licenses:
- Chronicall User
- Chronicall Realtime Agent
- Chronicall Dashboard Agent
You can verify these licenses from within Chronicall Desktop via User Management.
If any licensing changes have been applied, navigate to User Management and select Refresh Users and Groups. Now have the agent relaunch Chronicall to access the updated licensing.
Review Agent Dashboard Configuration
Review the Agent Dashboard configuration for the agent. Verify that all Dashboard values such as widgets, agent value, and general values are set up correctly for the agent.
Note: It can be helpful to review a different agent's configuration (that's working correctly) and mirror the setup if you are unsure of which values this agent should have assigned.
Enable Pop-Ups
When authenticated to the Agent Dashboard, right click on the blue X in the bottom right taskbar, and highlight Pop-ups. This should show a list of enabled pop-ups for the agent. Ensure that any applicable pop-ups for the agent are enabled.
Intermittent Pop-Ups
If pop-ups are intermittent or don't always launch, it may be a symptom of an underlying network issue. Any lag or missed packets on the local network can result in intermittent pop-ups as the Chronicall Server isn't able to relay the pop-up messages consistently to the local Agent Dashboard. It is recommended to disable Wi-Fi and try a direct connection on the same subnet to resolve the issue. If issues persist check with your network administrator to test the connection between the local user PC and the Chronicall server.