Overview
This article covers troubleshooting the issue where running a report generates the error "Could not initialize class sun.awt.image.ToolkitImage" preventing the report from displaying.
Cause
This error typically occurs when Java is updated or reinstalled while the Chronicall services are still running.
As a result, the working Java path that Chronicall uses doesn't get updated with the new Java version, or get removed.
Resolution
To resolve this issue, the Java path must be updated in the Chronicall settings to reflect the updated Java path. This can be done in one of two ways.
Note: If the customer cannot update, move on to Step 2.
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(Preferred method)
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For a permanent, long-term fix, please update Chronicall to the latest recommended version (3.10 or newer) found here as it contains an embedded Java package that makes local Java issues like this one obsolete.
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Note: Running a Chronicall update involves a brief restart of the Chronicall service which will stop all logging, recording and call routing
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Multimedia customers will need to perform this update after hours to avoid losing calls in queue.
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(Alternate method)
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Stop all Chronicall services and start them back up again or reboot the Chronicall server; whichever is more convenient.
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Multimedia customers will need to perform this update after hours to avoid losing calls in queue..
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If Step 2 fails, perform a fix for the "service will not start" issue covered in this article.