Issue Description
Chronicall keeps prompting to register the same user, and not remembering the previous license settings.
This usually occurs via a pop-up message when initially logging into Chronicall as shown:
Cause
This is most likely the result of a corrupted user configuration file. Changes are not able to save properly for that user, causing the system to continually display the user configuration pop-up.
Resolution
The corrupted user configuration file should be removed and recreated.
Steps
Remove user configuration file
- Navigate to the following file path based on your Chronicall server's operating system:
- Windows
- 32-bit
- C:\Program Files (x86)\Xima Software\Chronicall\tomcat\webapps\ROOT\resources\binary
- 64-bit
- C:\Program Files\Chronicall\tomcat\webapps\ROOT\resources\binary
- 32-bit
- Linux
- var/lib/Xima\ Software/Chronicall/tomcat/webapps/ROOT/resources/binary
- Windows
- Select the user configuration file
- Search it for the user or extension in question
- Move the individual user file(s) to a location outside of the binary folder for backup purposes
- Once a new user configuration file is created successfully (steps below), this backup user file can be removed
Recreate user configuration file
When services are restarted, (or you select Refresh Users and Groups) the Chronicall system will refresh the new user(s) and extension(s) data from the phone system and will then create any new user configuration files as needed.
- Restart the Chronicall service on the Chronicall server, or refresh Users and Groups
- Log into Chronicall, and assign the licenses as prompted
- If your user licenses auto-assign, you can navigate to User Management >> User Licenses to verify the user is showing as licensed.
- Close and relaunch Chronicall Desktop to verify the pop-up no longer shows for the same user(s)