Orient Service may launch but it dies shortly thereafter
All services were running except for the Orient service. If you relaunched it, it would run briefly then stop automatically after about 10 seconds.
Cause
Sometimes when an update runs, it will update the ports in the main Chronicall settings file, but not the Orient settings file. Also, see the special Shoretel note at the bottom of this article if on a Shoretel site.
Resolution
Steps
- Navigate to the file path below.
- 32-Bit Windows
- C:\Program Files (x86)\Xima Software\Chronicall
- 64-Bit Windows
- C:\Program Files\Xima Software\Chronicall
- Linux
- /var/lib/Xima\ Software/
- 32-Bit Windows
- Right-click the settings.xml file, and open it with Notepad or equivalent
- Verify the CDR ports in the document, as shown below -
- As you can see in this screenshot, the base port was normal, but the other 2 CDR ports had been changed to 10090 and 10091
- The ports were changed here with the update/migration but did not update in the Orient settings file. We'll need to update the port range there
- As you can see in this screenshot, the base port was normal, but the other 2 CDR ports had been changed to 10090 and 10091
- Navigate to the file path below -
- 32-Bit Windows
- C:\Program Files (x86)\Xima Software\Chronicall\orientdb\config\orientdb-server-config.xml
- 64-Bit Windows
- C:\Program Files\Xima Software\Chronicall\orientdb\config\orientdb-server-config.xml
- Linux
- /var/lib/Xima\ Software/orientdb/config/orientdb-server-config.xml
- 32-Bit Windows
- Right-click and open with Notepad or equivalent
- Find the 9090-9090 range, and change it to the range shown in the settings file from Step 3
- In this example, you would change it to 10090-10090
- In this example, you would change it to 10090-10090
- Find the 9091-9091 range, and change it to the range shown in the settings file from Step 3
- In this example, you would change it to 10091-10091
- In this example, you would change it to 10091-10091
- If the server is still not logging and you get an error that looks like this within the Tomcat logs even after changing the ports then doing a server reboot has been known to resolve the issue:
-
com.orientechnologies.orient.core.exception.OSecurityAccessException: User or password not valid for database: 'cdr'
NOTE: Sometimes on Shoretel sites port 10090 and port 10091 will already be in use by another program. In those instances, please use ports 9190 and 9191 respectively.