Issue Description
Calls are getting stuck while processing, and not populating to Cradle to Grave.
Cause
Typically this is a result of calls getting stuck in the Purgatory folder. Some common causes of this can be:
- Insufficient memory allocated directly to Chronicall
- A high volume of concurrent calls is creating more work than the server can handle
Resolution
Adjusting the Recording Library settings and then reprocessing the files in purgatory can allow those stuck calls to finalize into Cradle to Grave.
Adjust Recording Library Steps
- Open Chronicall and navigate to the Recording Library menu and adjust two settings there
- Simultaneous Encoder Count - Set it, at most, to one less than the total number of cores on the server
- E.g. If you have a 4-core CPU on the server, set it to 3
- This setting is the number of CPU cores to allow for recording processing. Do not increase if you do not have extra cores to utilize.
- Wait To Move To Limbo - By default, this should be 2 minutes (120 seconds)
- This will prevent recordings from being moved into Limbo before they are fully created
- This will prevent recordings from being moved into Limbo before they are fully created
- After those are switched, restart the Recording Library service for these changes to take place
Reprocess Recordings Steps
- Navigate to the Limbo folder on the Recording Library server
- This is typically located in the following file paths
- C:\Program Files (x86)\Xima Software\Chronicall\recording library\limbo
- C:\Program Files\Chronicall\recording library\limbo
- C:\Program Files\Avaya Call Reporting\recording library\limbo
- /var/lib/Chronicall/recording library/limbo
- This is typically located in the following file paths
- Right-click and copy the Limbo folder
- Navigate to where you want to paste the Limbo folder, paste it and then rename it "Old Recordings"
- Navigate to the Purgatory folder
- This is typically located in the following file paths
- C:\Program Files (x86)\Xima Software\Chronicall\recording library\limbo\purgatory
- C:\Program Files\Chronicall\recording library\limbo\purgatory
- C:\Program Files\Avaya Call Reporting\recording library\limbo\purgatory
- /var/lib/Chronicall/recording library/limbo/purgatory
- This is typically located in the following file paths
- Look for any recordings in the Purgatory folder that are not processing
- These will show as .wav files
- Stop the Recording Libary service
- Copy all the .wav files from the Purgatory folder into the Limbo folder
- Start the Recording Libary service
- Recordings should begin to process again
- Once they have been processed, you can delete the recordings in the Purgatory folder that were copied over as they may be duplicated or invalid recordings