Overview
This article covers various issues you may encounter running a new installation or update to the Chronicall software.
Cause
Chronicall processes and services can take some time to shut down during an update, and older versions of Chronicall (3.9.4 and earlier) can hit issues with Windows not recognizing Java has been updated.
Resolution
Determine Issue Source. Below are the most common causes of installation or update issues.
Serial Key Error
- Click on the bell on your Chronicall screen. Check for a serial key error, and if there is one, follow these steps to troubleshoot it.
Services Stopped Error
- It may take some time for Chronicall related services and processes to shut down.
- Below is a screenshot of the Recording Library taking some time to shut down. Give it some time to close and then select Retry.
- If Retry still doesn't work manually, shut down the related Chronicall services If it continues to hang in manual shut down of services, manually kill all Chronicall related processes, and try shutting down the services again and it will be successful.
End the update and re-run the update as an Administrator in Windows, or with Root access for Linux.
Permissions Error
For Windows, if you get an error saying that the Postgres folder (in the Chronicall directory) needs permissions adjusted for everyone, it is recommended that you disable User Account Control, and then restart the server and continue.
- Ensure the UAC (User Account Control) is fully disabled. If you set the slider was set all the way down it may still have issues. To do this, go into the Registry Editor and manually disable (fully turn off) UAC. It is recommended you have your system Administrator do this, as editing the registry can be dangerous on the Chronicall server.
Java Not Detected
This is a legacy troubleshooting step, as Chronicall 3.9.5 and higher have both 32-bit and 64-bit Java built-in. If you get an error that Java needs to be updated, verify you have updated to the most recent 32 bit Java offline installation.
If you are also using 64-bit Java to use higher allocated memory (RAM) for Chronicall, follow this article to verify all 64-bit Java paths have been updated.
Error Extracting Installation Files
During a server migration
- If the settings.xml file was carried over from the original server, it can contain an incorrect file path to the installation of Chronicall. This will cause a failure when you try to update/upgrade.
- Open the settings.xml file in Notepad with Admin privileges and edit to reflect the new file path.
During a Chronicall update
- Windows
- For the below Extraction Error, move the update file from the Downloads folder to a different directory like the Desktop or Documents folder and re-run the update.
- Verify the
chronicall.path
in the settings.xml and that the settings.xml file exists
- For the below Extraction Error, move the update file from the Downloads folder to a different directory like the Desktop or Documents folder and re-run the update.
- Linux
- The stack trace for the Extraction Error may look like this instead:
- If the "chronicall.path" value in the settings.xml file is correct, run the below command as root to create a symbolic link in `/etc/chronicall` to the settings.xml file:
- Chronicall
-
ln -s /var/lib/Xima\ Software/Chronicall/settings.xml /etc/chronicall/settings.xml
-
ln -s /var/lib/Chronicall/settings.xml /etc/chronicall/settings.xml
-
- Avaya Call Reporting
-
ln -s /var/lib/Avaya\ Call\ Reporting/settings.xml /etc/chronicall/settings.xml
-
- NOTE: The first part of either symbolic link command will need to be changed if Chronicall/ACR was not installed in the default directory
- The stack trace for the Extraction Error may look like this instead:
Chronicall Cannot Find The jvm.dll While Updating
- Due to various circumstances, such as a user's local antivirus/malware software, Chronicall may not be able to find the default Java path due to blocked communication. You may see errors such as the ones below
- In these instances, we need to update the Java path in the updater's config file
- Navigate to the unpacked updater folder
- This folder's name may start with Avaya Call Reporting or Chronicall depending on your version
- The unpacked updater folder is usually located in the same folder that you ran the update file from
- Navigate to bin > app within the unpacked updater folder
- Open up the ChronicallUpdate.cfg with a text editor
- Locate the app.runtime file path inside
- Update it to the full file path of the Java folder inside the unpacked updater folder
- Save this file to the same location
- Go back a folder and run the ChronicallUpdate.exe file as an Administrator.
- Navigate to the unpacked updater folder
Incompatible Version Error
When updating to 4.2 and above you may run into this error. This is usually caused by the file path being incorrect in the settings.xml file.
- Navigate to the settings.xml file for your installation of ACR/Chronicall
- Examples
- C:\Program Files\Avaya Call Reporting
- C:\Program Files\Chronicall
- C:\Program Files\Xima Software\Chronicall
- Examples
- Open the settings.xml file and make sure that the line for "chronicall.path" is pointed to the correct directory
- E.g.
<setting value="C:\Program Files\Avaya Call Reporting" key="chronicall.path"/>
- E.g.
- If it is incorrect:
- Stop all services
- Correct the chronicall.path and save the changes
- Restart Chronicall services
- Try to run the update again
Failed to Get License Bundle Error
2021-08-09 22:18:20.522 [ERROR] Failed to get license bundle. Using local license pack. url=http://rest.ximasoftware.com/chr/license?serial=serialkeyhere&created=2018-06-05%2003:34:45&version=4_2_9w&site_info=siteinfohere (LicenseBundleRequest.java:41)
When updating to 4.2.9 and beyond, we pull down the licenses through site info and not info hash. If the Chronicall server is online, it must be able to hit the licensing server to pull down the license bundle and site info information.
- To make sure rest.ximasoftware.com is not blocked, open a browser and navigate to the following URL: rest.ximasoftware.com/chr/license?serial=serialkeyhere
- If this URL resolves, it will download the license file from the rest.ximasoftware.com server, meaning it is not being blocked.
- If this URL does not download a license file, then it is most likely being blocked by the server/network's security.
- If the network admin confirms rest.ximasoftware.com is not being blocked, please check the hosts file to ensure there is not a loopback.
- On Windows, navigate here:
-
C:\Windows\System32\drivers\etc
- Open the Hosts file with notepad:
- If the above highlighted line exists in the hosts file, remove the entire line and save. This will prevent the server from looping back when trying to resolve rest.ximasoftware.com.
-
- On Linux open the Hosts file using your text editor:
-
nano /etc/hosts
- As with the Windows screenshot above, if the highlighted line exists, delete the entire line and save. This will prevent the server from looping back when trying to resolve rest.ximasoftware.com.
-
- On Windows, navigate here:
Failed to Instnatiate the Installer Error
-
This step covers how to fix a Null Pointer error being generated due to the feature toggle section in the settings.xml
- The following error will show in the stderr log, the relevant parts of this NullPointer are in RED
- Failed to instantiate the Installer:
- com.ximasoft.chronicall.jinstallation.IpoChronicallUpdate java.lang.reflect.InvocationTargetException at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:423) at com.ximasoft.jinstallation.JInstallationFramework.instantiateInstaller(JInstallationFramework.java:358) at com.ximasoft.jinstallation.JInstallationFramework.<init>(JInstallationFramework.java:169) at com.ximasoft.jinstallation.JInstallationFramework.main(JInstallationFramework.java:316) Caused by: java.lang.NullPointerException at com.ximasoft.feature.toggles.FeatureTogglesFromCollection.<init>(FeatureTogglesFromCollection.java:17)
- Failed to instantiate the Installer:
- The following error will show in the stderr log, the relevant parts of this NullPointer are in RED
- Check the settings.xml file in the main Chronicall or Avaya Call Reporting directory.
- If it doesn't look like it is shown below, In settings.xml add<setting key="feature.toggles"/>before the</configuration>at the bottom
Network Migration - Cannot Login on New Server
- Reference the error at the bottom of this network migration article if you have a recent network migration that doesn't appear to be working
- In one verified instance, I could not log in on a new server once the migration completed. A network migration from 3.12.7 to 4.4.7 failed to generate an encryption key in the settings.xml file, so I pulled one from our lab and added it to the settings.xml with services stopped and that allowed me to login to the new instance.